Can't see Zephyr Essential page content after the install

Incident Report for Zephyr Squad Cloud

Resolved

We found the issue and provided a fix.
Please wait for 30 seconds and reload the full page after installing the plugin.
Posted Jul 03, 2025 - 21:00 IST

Investigating

Team is investigating the issue
Posted Jul 03, 2025 - 15:52 IST
This incident affected: Zephyr Squad (Zephyr Squad Cloud (previously known as Zephyr for Jira Cloud)).