Last Sunday, a new version of Zephyr Squad Cloud has been released. This version required an app descriptor change, which Atlassian rolls out to all Jira instances automatically, usually within 10 hours.
This release caused an issue. Customers that have never tried the new experience (Zephyr Essential) were not be able to load the application anymore, and all menu items in Jira were labelled "Zephyr Essential" instead of "Zephyr Squad".
Once this has been reported, the Zephyr team promptly released a new version of the app descriptor, rolling back the previous change.
This time, Atlassian took just over 24h to rollout the descriptor to Jira instances automatically. Affected Jira instances were just fixed once they've had the new descriptor applied, so some instances might have experienced a longer donwtime than others.
As a workaround, we've been advising customers to manually click "update" to get the latest version of the app descriptor.
Posted Aug 05, 2025 - 20:29 IST
Resolved
This incident has been resolved hours ago, as we could confirm that customers were back on track using Zephyr Squad. For more information, please read the postmortem of this incident.
We sincerely apologise for the inconvenience, and we are taking action to prevent these issues to happen in the future.
Thank you.
Posted Aug 05, 2025 - 20:28 IST
Update
This issue has been fixed many hours ago. We have confirmation from many customers that the fix deployed has resolved the issue for them.
However, we are seeing many customers not getting an automatic update on their instances, causing the fix to not rollout to everyone. If you are still being affected by this problem, please navigate to "Manage apps" and click to update Zephyr Essential to get the latest fix deployed to your Jira instance.
Our apologies for the disruption. Please feel free to reach out to us at anytime if you have any questions.
Posted Aug 04, 2025 - 20:38 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 12:55 IST
Investigating
Hi All,
We want to make you aware that Zephyr Squad Cloud (previously known as Zephyr for Jira Cloud) application is facing intermittent issues. We value your work and trying our best to resolve this issue ASAP.
The issue is causing users to see "Zephyr Essential" on the UI rather than "Zephyr Squad". Rest assured that no data loss is associated with this issue.