Urgent Maintenance Activity Notice
Incident Report for Zephyr Squad Cloud
Resolved
This incident has been resolved.
Posted Jul 26, 2020 - 13:41 IST
Identified
Hi All,

We are performing urgent maintenance in Zephyr for Jira cloud instance. We value your work and will try our best to minimize the impact.

We appreciate your patience and understanding. As always, if you have any questions or issues, please contact https://support.smartbear.com/zephyr-for-jira/
Posted Jul 26, 2020 - 13:20 IST
This incident affected: Zephyr Squad (Zephyr Squad Cloud (previously known as Zephyr for Jira Cloud)).