Zephyr Squad Cloud (previously known as Zephyr for Jira Cloud) Intermittent Performance Issues

Incident Report for Zephyr Squad Cloud

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 23:12 IST

Investigating

Hi All,

We want to make you aware that Zephyr Squad Cloud (previously known as Zephyr for Jira Cloud) application is facing intermittent issues. We value your work and are trying our best to resolve this issue ASAP


We appreciate your patience and understanding. As always, if you have any questions or issues, please contact https://support.smartbear.com/zephyr-for-jira/
Posted Mar 10, 2025 - 22:25 IST
This incident affected: Zephyr Squad (Zephyr Squad Cloud (previously known as Zephyr for Jira Cloud)).